Videos Not Working in Preview App

Discuss all aspects of the HTML5-based AppStudio: From content design and enrichment in InDesign CS5.x, CS6 & CC and/or QuarkXPress 9.5, 10, 2015 & 2016 to creating your app, submitting it and publishing it to Android tablet, Android phone, iPad, iPhone and Web Apps. Free Trial can be found here: http://AppStudio.net

Videos Not Working in Preview App

Postby deike1976 » 14 Feb 2017, 13:21

I've managed to get my videos working in App Studio's web previewer but when I push them out to the preview app not all of them work. They're all .mp4 files. I'm previewing using an iPad. Please help.
deike1976
 
Posts: 5
Joined: 14 Feb 2017, 13:11

Re: Videos Not Working in Preview App

Postby deike1976 » 15 Feb 2017, 09:03

Ok, it seems to me that the preview app only supports one video per page, and whatever video is on top in the layers panel in InDesign is the one that will play. Can anyone confirm that? Thank you.
deike1976
 
Posts: 5
Joined: 14 Feb 2017, 13:11

Re: Videos Not Working in Preview App

Postby deike1976 » 15 Feb 2017, 14:32

After a lot of trial and error I have found that I can play only one video per file on the preview application. In order to do what I wanted to do, which was play multiple videos, I had to convert my simpler videos to GIFs. Everything worked in the preview application afterwards.
deike1976
 
Posts: 5
Joined: 14 Feb 2017, 13:11

Re: Videos Not Working in Preview App

Postby srmareedu » 16 Feb 2017, 00:22

Hi Deike,
I think you are using InDesign Application. Please make sure that all your videos are placed in same layer other than background layer. if you still face the problem, you please send your InDesign Document to my mail ID srmareedu@quark.com . I will verify and let you know
Thanks
Srinivas
srmareedu
Quarkian
Quarkian
 
Posts: 32
Joined: 30 Apr 2015, 06:23

Re: Videos Not Working in Preview App

Postby deike1976 » 16 Feb 2017, 09:16

Yes, I'm using InDesign. My videos are in the same layer other than background. I will send you the file. Thanks.
deike1976
 
Posts: 5
Joined: 14 Feb 2017, 13:11

Re: Videos Not Working in Preview App

Postby srmareedu » 21 Feb 2017, 06:15

Hi Deike,
I have verified your InDesign document and noticed that you have placed multiple videos on same page with Auto play option. Multiple videos with Auto play does not work simultaneously on iOS. you can refer below Apple Developer link..

"Currently, all devices running iOS are limited to playback of a single audio or video stream at any time. Playing more than one video—side by side, partly overlapping, or completely overlaid—is not currently supported on iOS devices. Playing multiple simultaneous audio streams is also not supported."

https://developer.apple.com/library/con ... 3-CH5-SW10


Thanks
Srinivas
srmareedu
Quarkian
Quarkian
 
Posts: 32
Joined: 30 Apr 2015, 06:23

Re: Videos Not Working in Preview App

Postby deike1976 » 28 Feb 2017, 10:08

Ok, thank you for your help.
deike1976
 
Posts: 5
Joined: 14 Feb 2017, 13:11


Return to App Studio – Design and Publish Native Apps using HTML5

Who is online

Users browsing this forum: No registered users and 1 guest