Videos and Hyperlinks in Apps

Discuss all aspects of the HTML5-based AppStudio: From content design and enrichment in InDesign CS5.x, CS6 & CC and/or QuarkXPress 9.5, 10, 2015 & 2016 to creating your app, submitting it and publishing it to Android tablet, Android phone, iPad, iPhone and Web Apps. Free Trial can be found here: http://AppStudio.net

Videos and Hyperlinks in Apps

Postby chrisoshea » 17 Apr 2014, 04:00

HelloI've been struggling the last few days now trying to get these two features to work properly, but without success. I'm using the dedicated Video option in the HTML5 palette as opposed to a Play action through a Button. I've tried embedding video - and that was the closest I've come, but only the sound played, without the actual video. It was a large, HD video which made the upload huge and slow, but I can see the potential in that at least. Incidentally, the video in question plays fine on my Android phone's stand-alone mp4 player, but it won't play when viewed through the App Studio Previewer app. I've also tried entering a URL to a video on YouTube, and I tried the same URL using the YouTube/Vimeo option. The video doesn't play with any of these options.Second problem is Hyperlinks. I've created a simple button and used the Go To Page action. I got the Article ID from the App Studio flatplan as recommended, and have tried every variation of the Article ID I can think of, including:articleById://Lakes_App//Lakes_AppLakes_App://Lakes_Appand none of them work. I know they won't work in the Browser Previewer, but they don't work when I upload to Test and check in the App Studio Previewer app either. I've read several of the posts on here and I know it must work as most people seem to have cracked it, but I'm obviously missing something very basic here. Please help!
chrisoshea
 
Posts: 51
Joined: 05 Oct 2004, 07:02

Videos and Hyperlinks in Apps

Postby glacierphotos » 20 Apr 2014, 07:57

Which version of Quark are you using?
glacierphotos
 
Posts: 167
Joined: 01 Sep 2008, 22:13

Videos and Hyperlinks in Apps

Postby chrisoshea » 22 Apr 2014, 00:22

I'm using v10 for Windows. Managed to get the Goto page links working now - not quite sure why they didn't work before or what I've done differently, but looks lije that one is solved. Videos are still a mystery - I managed to get a very small embedded clip to work, but still only get sound or nothing at all when linking to either a URL or a YouTube/Vimeo clip.
Thanks for any suggestions...
Chris
chrisoshea
 
Posts: 51
Joined: 05 Oct 2004, 07:02

Videos and Hyperlinks in Apps

Postby Matthias Guenther (Quark) » 22 Apr 2014, 01:22

Hi Chris,
have you seen the examples? Also, are you testing on Android or iOS please?
Thanks
Matthias
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5445
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Videos and Hyperlinks in Apps

Postby chrisoshea » 22 Apr 2014, 01:30

Hi Matthias
I've looked at some of the threads on here but not sure if they're the examples your referring to?
I'm using Quark 10 for Windows and testing on Android.
Chris
chrisoshea
 
Posts: 51
Joined: 05 Oct 2004, 07:02

Videos and Hyperlinks in Apps

Postby Matthias Guenther (Quark) » 22 Apr 2014, 01:32

Hi Chris,
I meant the examples in the Previewer app, it shows how to set up each enrichment.
Fullscreen video unfortunately currently has a bug under Android, so it doesn't show up full screen. It will be fixed in the next release of the Android app. If you can check on iOS, it should work fine.
If you need a fix now, a full screen popup with a larger video coudl work.
Regards
Matthias
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5445
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Videos and Hyperlinks in Apps

Postby chrisoshea » 22 Apr 2014, 01:40

Hi Matthias
Where would I find the examples in the Previewer App? I just downloaded and installed it, but didn't see anything about examples anywhere.
I haven't even tried full-screen videos yet - I'd be happy if I could just get any video, other than very short embedded ones, to play, in any kind of view! I did try using a pop-up as well at one stage, but still couldn't get a video to play on the Android Previewer app.
Chris
chrisoshea
 
Posts: 51
Joined: 05 Oct 2004, 07:02

Videos and Hyperlinks in Apps

Postby Matthias Guenther (Quark) » 22 Apr 2014, 01:41

Hi Chris,
when you log out of App Studio Previewer app, you should see the manuals within the app.

Thanks
Matthias
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5445
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Videos and Hyperlinks in Apps

Postby Matthias Guenther (Quark) » 27 May 2014, 05:14

Hi all,
Matthias Guenther (Quark) wrote:Fullscreen video unfortunately currently has a bug under Android, so it doesn't show up full screen. It will be fixed in the next release of the Android app. If you can check on iOS, it should work fine.

This is now fixed in v2.9 of the Android app: http://docs.appstudio.net/display/AppStudio/Android+release+history
Thanks
Matthias
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5445
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Videos and Hyperlinks in Apps

Postby steveb » 08 Jul 2014, 15:08

I too am having problems with linked YouTube videos. The links work on iOS but not on Android. The YouTube poster image and button show up just fine, but on some devices (Kindle Fire HD 7 and HD 8.9) the audio plays, but no video, when the button is tapped. On others (Nexus 7) nothing happens at all.

I've checked the Enrichment Guide documents but they seem to include only embedded videos, not linked videos.

Appreciate any thoughts. Thanks.

Steve
steveb
 
Posts: 8
Joined: 27 Jan 2014, 15:39

Next

Return to App Studio – Design and Publish Native Apps using HTML5

Who is online

Users browsing this forum: No registered users and 1 guest