crashes when working with text with polish characters

Discuss functionality of QuarkXPress 10, 9 & 8 (and before) (excluding Digital Publishing).
For Digital Publishing functionality please refer to forums in the "Digital Publishing" group.

As QuarkXPress 1 thru 10 are not supported by Quark anymore, please upgrade to a newer version of QuarkXPress if you are looking for official support. Support options for supported versions are here: http://support.quark.com

crashes when working with text with polish characters

Postby petas » 27 Jan 2017, 08:41

Hello Quark Forum,

I need help. Today my Quark started to shut down everytime I wanted to edit text with polish letters/characters.
I am working with Quark 8.02 on windows 10 and had never trouble like that before. I do work a lot with different languages/characters (mostly scandinavian, german, some russian ... and since today I was supposed to work with polish text). The text comes from a word document (2 pages - only text).

It took me a while to exclude other reasons that could cause this behaviour. I tried with some dummy text without special characters in the same conditions just to exclude that it is a general problem ... everything worked fine. So it must be that polish text ... in one way or another.

I removed all styling from the polish text in Word with no result. Quark shuts down as soon as that text is placed into a textframe and I want to start editing it. (only to touch a corner of that text frame can be enough and Quark shuts down immediately). This is pretty frustrating and I have no idea how to fix that problem.

Does anyone here knows something about that problem? Any ideas how to fix that? Some similar experiences?
Any help is appreciated!

Thanks in advance.
Kind regards,
Peter
petas
 
Posts: 4
Joined: 27 Jan 2017, 06:44

Re: crashes when working with text with polish characters

Postby MikeWenzloff » 27 Jan 2017, 09:43

Peter,

Note that version 8 is not supported on Windows 10. So before anything below, I would encourage you to make a system image so if something goes wrong you can roll back without issue.

Note that I am using a newer version. And your version is not the last in the version 8 series. So the first thing I would recommend is going to the Quark web site and find the later updates, download and install them. And probably delete your preferences before starting Q back up.

It could be some of the hidden formatting in Word still. If so, copy some of the Word file and paste it into a text editor that handles Polish characters properly, then copy and paste that into a new document. Does it still crash?

It could be the font itself. Do other fonts cause the crash? Again, it likely should be tried in a new document.

I have no issues myself with the Polish language in QXP on Windows 10.

Mike
MikeWenzloff
 
Posts: 1151
Joined: 05 Jun 2013, 12:55

Re: crashes when working with text with polish characters

Postby petas » 27 Jan 2017, 10:23

Thanks a lot Mike for quick response and proposals!
I appreciate that!

Updating Quark is definetely a good idea. I will do that (had that in mind for a while now...so why not now).

The text editor/clean document solution made no difference. Quark crashes.
This is quite mystical...

What could that be? And how to fix that? Please, help!!!

Peter
petas
 
Posts: 4
Joined: 27 Jan 2017, 06:44

Re: crashes when working with text with polish characters

Postby MikeWenzloff » 27 Jan 2017, 10:29

Hi Peter,

It could be as simple as deleting the preferences...but because you are using version 8 on Windows 10, I would do the update first then delete the preferences before starting the updated QXP.

May I ask what font you are using? Is it a older PostScript Type 1 font? If so, how about trying just plain old Arial? Does that make a difference in a new document?

Can you share a small amount of text that causes a crash there? I have version 9 installed but not 8. If you can share some text that still causes a crash, then you can either ZIP it up and attach it here on the forum or send me a link via a private message to download from a place like dropbox. Or, we can exchange email addresses via the private message. Your choice if you can share some text.

Mike
MikeWenzloff
 
Posts: 1151
Joined: 05 Jun 2013, 12:55

Re: crashes when working with text with polish characters

Postby petas » 27 Jan 2017, 11:16

Thanks again, Mike!

...I am downloading the update right now and will install it.I have to leave the office now for the moment, but will let you know what happened after updating Quark.

For the font I was using pre-installed Georgia (TrueType) Tried as well good old arial. No experiments :)
I am not allwoed to contact you via private message or attache files. :( (since this is my first time in this forum). Would be really interesting to share some of that text and see what happens.

Again, thanks a lot!
Peter
petas
 
Posts: 4
Joined: 27 Jan 2017, 06:44

Re: crashes when working with text with polish characters

Postby petas » 27 Jan 2017, 14:03

Finally I found it out (after some really useful hints from Mike!).

It was the embedded encoding in the Word file that caused the problem. When forcing word to remove all formatting by converting the file into plain text it showed a warning that the coding needs to be changed. So I changed it to unicode. After that I could import the text file into Quark without any problems. PHEW!!! Solved!

Thanks again Mike for quick help and friendly assistance!

Regards,
Peter
petas
 
Posts: 4
Joined: 27 Jan 2017, 06:44

Re: crashes when working with text with polish characters

Postby MikeWenzloff » 27 Jan 2017, 16:55

Great news, Peter!

If you need anything else, I usually pop in a couple times a day, sometimes more if I post so as to make sure I follow-up. I too was out for a time, so am especially happy it is resolved.

Take care, Mike
MikeWenzloff
 
Posts: 1151
Joined: 05 Jun 2013, 12:55


Return to QuarkXPress 8, 9 & 10: General

Who is online

Users browsing this forum: No registered users and 1 guest