Need Quark updater, link on this site doesn't work

Discuss functionality of QuarkXPress 10, 9 & 8 (and before) (excluding Digital Publishing).
For Digital Publishing functionality please refer to forums in the "Digital Publishing" group.

As QuarkXPress 1 thru 10 are not supported by Quark anymore, please upgrade to a newer version of QuarkXPress if you are looking for official support. Support options for supported versions are here:

Need Quark updater, link on this site doesn't work

Postby SarahB1863 » 23 Jan 2018, 14:47


I need the Updater to upgrade Quark 9.5.1 to Quark I downloaded the updater from the site, but when I opened it I got an error message that the updater "could not be installed because the digital signature doesn't match and may be corrupt or tampered with."

Can anyone help me? Thank you!
Posts: 1
Joined: 23 Jan 2018, 14:43

Re: Need Quark updater, link on this site doesn't wo

Postby Matthias Guenther (Quark) » 23 Jan 2018, 16:24

Hi Sarah,

why do you need The latest update for QuarkXPress 9 was

Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:

User avatar
Matthias Guenther (Quark)
Posts: 5399
Joined: 04 Jun 2004, 15:06

Return to QuarkXPress 8, 9 & 10: General

Who is online

Users browsing this forum: No registered users and 1 guest