Page 1 of 1

QuarkXPress 7, 8, 9 & 10 might soon NOT run on MacOS anymore

PostPosted: 12 Apr 2018, 03:52
by Matthias Guenther (Quark)
Hi all,

Apple has started the beginning of the end of 32-bit apps on MacOS:
"Starting with macOS High Sierra 10.13.4, apps that have not been updated to use 64-bit processes produce a one-time alert when opened."
https://support.apple.com/en-us/HT208436

So currently it is just an alert. Apple also announced that the next version of MacOS – which is likely to be released in Sep 2018 – will be the first version of macOS to not fully support 32-bit applications.
There's not more information available by Apple currently, it could mean that they will not work at all or that Apple removes Carbon (which many 32-bit application use).

If you are using QuarkXPress 2015, 2016, 2017 and 2018 there is no need to worry, as they are all 64-bit applications.
(Please nevertheless check version compatibility.)

If you are using QuarkXPress 7, 8, 9 or 10, then you should watch Apple closely and continue to use MacOS version 10.13 or earlier.
(Please note that officially QuarkXPress 10 and before are not supported on High Sierra anyhow, though they typically run with minor flaws on High Sierra.)

Thanks
Matthias