Mac 10.10.5 / Quark 9.5.4.1 Fonts won't load.

Discuss fonts and font usage in QuarkXPress workflows on MacOS® and Windows® in QuarkXPress 8, 9 & 10.

Mac 10.10.5 / Quark 9.5.4.1 Fonts won't load.

Postby WebQuark » 22 Oct 2015, 01:51

From one day to the other (had been working without problems for over a year), suddenly I cannot load new/in document missing fonts through Font Book, Suitcase Fusion and or Font Explorer X (all the latest versions) which will show up in Quark Xpress - but in -every- other application I use, Illustrator, indesign, Photoshop, Word etc etc, they show without any problem.

Even tried adding fonts directly into system folders but no success (this trick used to work in the past when I also had issues with fonts and an older version of QXP). Flushed application font cache, flushed system font cache, optimized font database, all several times, restarted computer several times. Tried removing QXP preferences, nothing works.

I have searched the internet and these forums intensively as well and it seems that I am far from alone with this but a conclusive solution to this major bug I cannot find. :(


Really need to get this solved as soon as possible because I have work to do and that isn't possible at the moment.
Is there anybody who can help me?
WebQuark
 
Posts: 11
Joined: 30 Oct 2013, 04:06

Re: Mac 10.10.5 / Quark 9.5.4.1 Fonts won't load.

Postby dehaas1 » 10 Dec 2015, 16:38

I have the same problem! I just "collected for output" a file and some of the fonts didn't load. The printer told me that this is a problem with Quark 10 (only!) What do you do to fix this problem!!!!

I am extremely disappointed in this software...
dehaas1
 
Posts: 2
Joined: 10 Dec 2015, 16:31

Re: Mac 10.10.5 / Quark 9.5.4.1 Fonts won't load.

Postby WebQuark » 11 Dec 2015, 03:05

Possible solution?
In the end I did manage to find a solution or work-around for mac with QXP 9.5.4.1 - but if it works every time with every QXP version, not sure.

- I copied all the needed fonts to my user -> library -> fonts directory (make sure you select the correct directory: see point 6 at https://www.maketecheasier.com/option-key-mac/) and then restarted the computer.
All fonts were available in QXP after that but some time later one font, which was also copied to that library, was missing again. :(
- I then double clicked on the font (from the user -> library -> fonts directory) and the application that then opens (called Font manager or so), is the font manager when you're on mac; I searched for the missing font and strangely enough it showed as activated, I then de-activated it and activated it again ... problem solved after that. Some days later I had it again and then it showed as de-activated; in that case I activated it of course.

Although above may be a solution, it is very strange and dissapointing to see that ONLY Quark XPress has this problem .... :(
This problem isn't new and I am very disappointed to see that there is no support either. As customer you're on your own with this. :(
WebQuark
 
Posts: 11
Joined: 30 Oct 2013, 04:06

Re: Mac 10.10.5 / Quark 9.5.4.1 Fonts won't load.

Postby Matthias Guenther (Quark) » 11 Dec 2015, 09:50

Hi,

could you two please elaborate on the problem as I unfortunately do not understand exactly what the problem is?

Maybe some background: QuarkXPress 10/2015 on Mac uses OS X's Cocoa technology to recognize fonts. That means when you activate it via FontBook (Apple's Font Manager) then QuarkXPress will see it. So if it shows activated in Font Book, QuarkXPress should offer it too. Otherwise it's a bug. You can alternatively do a test: Open TextEdit or any other app by Apple and see whether it shows there. If it does, QuarkXPress should see it too. Otherwise it would be a bug in QuarkXPress.

Now, if you use other Font Managers to enable fonts, then it is a bit more difficult, as they handle font handling. So it is more likely a bug in the Font Manager you are using or in the interface with QuarkXPress.

Also, if a font shows in Adobe's products or Microsoft's products, it doesn't mean that they will show in QuarkXPress, as they use private folders to enable fonts. Do the test with TextEdit again please: If that doesn't see it, it is such a privately activated font.

And lastly, collecting for output DOES NOT activate fonts. It copies fonts used into a folder but does not activate them from there.

So please let me know which font manager you are using and what the test in TextEdit showed.

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5246
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Mac 10.10.5 / Quark 9.5.4.1 Fonts won't load.

Postby dehaas1 » 11 Dec 2015, 13:40

I just collected a file for Out put and it didn't collect about 15 of the fonts that showed up in my font book. When I opened an apple app they showed up. You are saying that this means I have a bug, right? How do you fix that??
dehaas1
 
Posts: 2
Joined: 10 Dec 2015, 16:31


Return to QuarkXPress 8, 9 & 10: Fonts and fonts usage

Who is online

Users browsing this forum: No registered users and 1 guest