Quark 2015 not compatible with Suitcase Fusion in El Capitan

Discuss third-party XTensions® software for QuarkXPress 2015 and QuarkXPress 2016.
As the API hasn't changed between 2015 & 2016 versions, most XTension running in QuarkXPress 2015 should also work in QuarkXPress 2016.

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby shaun » 19 Oct 2015, 15:14

You can get the Quark 2015 extension from Extensis.
But since you had Suitcase installed before you got Quark 2015 why not get the latest version of Suitcase and install/re-install it? Part of the installation process is adding the auto-activation plug-ins for Quark and Adobe applications.
shaun
 
Posts: 337
Joined: 14 Jan 2006, 13:12

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby djt » 19 Oct 2015, 15:45

Yes, thank you. What I see in Library > Preferences > Quark > are 8 folders as follows:

jaws
QuarkXPress 6.0
QuarkXPress 7.0
QuarkXPress 8
QuarkXPress 9
QuarkXPress 10
QuarkXPress 2015
QuarkXPress Document Converter

NOTE: I currently have only Quark 9, 10 and 2015 installed on my MacPro (2013), the other 'Preferences' folders apparently all got migrated over from my old G5 when I bought the new MacPro in 2014.

This raises some interesting questions, as far as keeping the MacPro clean from useless clutter that may be slowing it down.

The question is, if Quark is no longer supporting Quark 9 and earlier – and they apparently won't be updated to work in El Capitan – then I'm wondering whether I should just delete these old folders and the associated Quark programs in the Applications folder entirely? Unless there is some kind of legacy registration or other software association link I need to maintain?

What is the 'jaws' folder, is it current and necessary? Inside the 'jaws' folder is
> 'FontStubs' folder >
_edir_
EAFonts
FontSet
WesternFonts (containing 6.3 MBs of fonts – what looks like a shortlist of old system standard fonts)

I'm always afraid to delete anything I don't know may be necessary. Thoughts?
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 20 Oct 2015, 08:05

Hi djt,

djt wrote:What I see in Library > Preferences > Quark > are 8 folders as follows:
  • jaws
  • QuarkXPress 6.0
  • QuarkXPress 7.0
  • QuarkXPress 8
  • QuarkXPress 9
  • QuarkXPress 10
  • QuarkXPress 2015
  • QuarkXPress Document Converter

NOTE: I currently have only Quark 9, 10 and 2015 installed on my MacPro (2013), the other 'Preferences' folders apparently all got migrated over from my old G5 when I bought the new MacPro in 2014.

This raises some interesting questions, as far as keeping the MacPro clean from useless clutter that may be slowing it down.


The Jaws folder is basically QuarkXPress' font cache and yes, you should clean it sometimes, especially when experiencing issues with fonts. The standard font cleaning tools can do that for you, e.g. Onyx.

About the preference folders from older versions, they don't slow down anything. E.g. if there's no QuarkXPress 8 installed, then nothing ever accesses that folder, so it doesn't have any affect on performance. You solely save a few KB diskspace if you delete it. So feel free to do so.

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5164
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 19 Nov 2015, 04:21

Hi all,

Extensis posted an update:
http://forums.extensis.com/viewtopic.php?f=58&t=4945

So looks like this will be resolved soon.

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5164
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby shaun » 11 Jan 2016, 17:01

Suitcase Fusion updated today.
Working on El Capitan. I've tested a load of files and all loaded with the correct fonts.
NB I still get the message about 'missing fonts', but when the file is fully open they all appear as required.
Keep your fingers crossed, but it looks like this plug-in is now auto-activating correctly.

Here's that damn message, by the way; irritating, and incorrect!
Attachments
Screen-Shot.jpg
Screen-Shot.jpg (44.41 KiB) Viewed 9984 times
shaun
 
Posts: 337
Joined: 14 Jan 2006, 13:12

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby djt » 11 Jan 2016, 19:13

Three things:
1. Thank you for emailing me the notice, as I never got a notice from Extensis.
2. I downloaded and installed the update. It showed that the Quark 10 and Quark 2015 plugins are now installed.
3. When I opened the Suitcase Fusion 6 font window I noticed that navigation between the font folders is just as slow as it was. Which is a full 5 second delay between all navigation clicks within SF6.

As far as how well it works with auto-activation in Quark 10 and Quark 2015, that will have to wait until I have more time to kill.

Conclusion, SF6 Quark plugins may or may not work with Quark now, but its speed is still terrible under OSX El Capitan.

Again, thank you for the heads-up.
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 17 Feb 2016, 02:02

Hi all,

this seems to be fixed now:
http://forums.extensis.com/viewtopic.ph ... =10#p19886

Regards
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5164
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby djt » 17 Feb 2016, 04:44

I just installed the Extensis Suitcase Fusion 6 update version 17.3.2 on top of the recent Quark 11.2.0.2 update under El Capitan 10.11.3 – and unfortunately the results are not good. In fact the performance is now worse than it was before, which was already very problematic with regard to speed and PS font rendering.

Specifically:
Basic PS fonts like Helvetica and Helvetica Narrow no longer show up in my recent Quark 2015 document – a simple all type 13 page manuscript that uses a few basic styles of Helvetica.

Helvetica Nue in True Type renders okay, but not the PS versions. Prior to these latest updates I was already having problems with a few Post Script 1 fonts, now even basic Helvetica Regular PS isn't rendering anymore – it was last week before I updated these apps.

I have a few True Type versions of Helvetica that came with the system I think so I was able to salvage that one document. But as a professional art director I've used many PS 1 fonts for many years, and have many legacy files that I can no longer properly open and render.

I cannot stress enough how serious this is. I have a top of the line MacPro (late 2013) SSD 64 GB RAM, so it is not my Mac. I really need a solution. Thank you.
Last edited by djt on 17 Feb 2016, 17:43, edited 1 time in total.
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 17 Feb 2016, 06:22

Hi djt,

that doesn't sound good. Can you please alert Extensis of this behavior as they are the maker of the XT?

We will of course also alert them and had hoped that this would solve everything. And maybe they have a solution, hopefully it is just a matter of deleting caches?

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5164
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby shaun » 17 Feb 2016, 09:50

Official installer for Suitcase Fusion and El Capitan loaded this morning.

Font activation was fine with last version of beta version - (January 26th)
(all fonts loaded properly both when Quark opened first from Dock and from double-clicking a file to open Qk).
Now if you double-click a file you get (a) no activation, (b) some activation or (c) complete activation. All very confusing.

(Still get the message that fonts are missing when in fact they are not.)


[Unchanged from last comment to Extensis:
Note: I am testing El Capitan on an external drive; this is connected to a MacBook running Yosemite.
Installing today's beta version also changed the Fusion extension in the Quark on Yosemite. Checked this version; it crashed instantly, when activated from Dock or file. Removed Fusion xtension from this version and replaced it with backup copy of previous xtension.]

If Apple produces a new OS next year are we going to go through this battle all over again?
I'm getting too old for all this messing about and am seriously contemplating deleting Fusion and installing something else. Font Agent Pro looks promising.
shaun
 
Posts: 337
Joined: 14 Jan 2006, 13:12

Previous

Return to QuarkXPress 2015/2016: XTensions modules for QuarkXPress

Who is online

Users browsing this forum: No registered users and 1 guest

cron