Quark 2015 not compatible with Suitcase Fusion in El Capitan

Discuss third-party XTensions® software for QuarkXPress 2015 and QuarkXPress 2016.
As the API hasn't changed between 2015 & 2016 versions, most XTension running in QuarkXPress 2015 should also work in QuarkXPress 2016.

Quark 2015 not compatible with Suitcase Fusion in El Capitan

Postby djt » 14 Oct 2015, 17:05

I just got off the phone with Extensis (Suitcase Fusion 6) tech support. They explained to me that there is a "known issue" with El Capitan that Quark and Extensis know about. This is a known problem AFTER the Quark 2015 v11.2 update.

PROBLEM:
Opening legacy (Quark 10 or earlier) files in Quark 2015 in OX 10.11 El Capitan displays empty text boxes.

Extensis tech support says it is related to the auto font activation feature (plug-in) in Suitcase 6 when used with Quark 2015. Not with other apps, just Quark. He says Quark and Extensis know about this but he does not know who will be addressing it. Quark tech support, if you can find them, know nothing of this issue as I can find.

THE WORK AROUND:
Extensis tech support explained that in Suitcase Fusion 6, under "manage plugins", uncheck the Quark boxes. So Suitcase will no longer 'auto activate' the fonts you are using. So you will need to activate them manually by dragging the font you want to use into the OS X > Library > Fonts Folder. (It will copy it there)

After you quit and relaunch Quark, and open the legacy Quark file, the correct typeface will show up again as expected now.

So it is up to Quark and Extensis to work out a patch. It would be nice of Quark actually let QX 2015 owners know, but I wouldn't hold your breath. I have yet to to receive one single notification from them, despite registering for 'newsletters and communications'.
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 15 Oct 2015, 03:24

Hi djt,

can you maybe check your spam folder? Quark sends out regular emails, a monthly newsletter and a weekly or fortnightly special emails if you opted in for that. For example a few days before the release of El Capitan we warned users of upgrading until QuarkXPress is compatible. And then when it was, we informed users about it too, so you should have received at least these two mails.

We are in contact with Extensis and analyzing together where the issue is. Last info I have is that they are working on a fix.

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5217
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby shaun » 15 Oct 2015, 10:12

Workaround: open Quark 2015, then open a file. The fonts should then show up. (This was a suggestion on the SF6 forums)
Opening Quark by first clicking on the file will sometimes, but not always, display the correct fonts.
shaun
 
Posts: 339
Joined: 14 Jan 2006, 13:12

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby djt » 15 Oct 2015, 12:23

Thank you for the quick reponse.

Yes, I check my spam filters regularly. As a registered Quark user since 1989, I used to get an occasional newsletter from Quark, but hadn't since around last January.

Prior to upgrading to Quark 2015 I followed the sales reps explanation for navigating the Quark website, I "opted in" to receive the 'newsletter and communications'. Yet I have not received anything except sales receipts, my order confirmation, and support responses to tickets that resolve nothing. I didn't even get the latest announcement for the El Capitan compatibility patch update, although that was my very first support ticket.

The bigger issue here is, that I have loyally stuck with Quark for decades, but like many of my colleagues – who are or already have abandoned Quark – I continue to have a very bad experience with every single interaction. Namely, a buggy, incompatible app, a website that requires me to reset my password(s) each upgrade cycle that I revisit it, sales reps who literally disappear and don't keep their appointments to call me after making an appointment to do so, endless upgrade charges for a program that doesn't really offer any more stability or features that I use, but instead gets slower and suffers from fewer and fewer third party companies – that used to make great xtensions, but who have also abandoned the platform. Over the years I have spent a small fortune on xtensions that are all obsolete now.

Frankly, the last time Quark actually launched without the beach ball and was stable was Quark 8.5 or maybe 9. Quark 10 and 2015 take a ridiculously long time to just launch – on my 6-core MacPro (late 2013) with 64 GB DDR RAM. This latest fiasco of first not being compatible with El Capitan, and now Suitcase Fusion 6 only continues to make me want to move on. Okay, I'm done ranting.

QUESTION: Is there anyway to be notified once this Suitcase Fusion 6 - Quark 2015 compatibility patch is ready? So that I can use Quark 2015. You'd think this would be pertinent news worth sharing, rather than leaving it up to the customer to search for. Respectfully, djt
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 19 Oct 2015, 02:46

Hi djt,

we checked our database, you are correctly configured for receiving communication and you are not on the black list, so you should be getting all emails we are sending out regularly. Maybe something is stuck, should we delete your account and you subscribe again?

djt wrote:Quark 10 and 2015 take a ridiculously long time to just launch – on my 6-core MacPro (late 2013) with 64 GB DDR RAM.

On my MacBook Pro with around 1,000 fonts it takes 5 secs for QuarkXPress 2015 to launch. You should see a similar time. Have you tried deleting preferences and disabling the font extensions?

Thanks
Matthias

P.S.: Same result in our tests about startup time, here's a Mac that's deliberately slow (with lots of profiles and fonts):
Image
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5217
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby djt » 19 Oct 2015, 03:35

"Have you tried deleting preferences and disabling the font extensions? "

Thank you, that sounds like a good idea - until Extensis delivers a fix: However, when I looked before in the Quark xtensions folder, oddly I found no Extensis Suitcase xtension. Even my old Quark 9 and 10 folders don't have one. I'm thinking either I'm not recognizing it, or maybe they just activate fonts via their plug-ins manager now - which I already disabled and helped eleviate the crashes to a degree. Or I'm nit recognizing the name?

Questions:
Do you know what the Extensis xtension is named?
And would you kindly remind me how to delete the preferences you suggested as it's been years since I've done that. Hopefully that might help eliminate some of the Quark 2015 crashes as well?

I'm also thinking maybe deleting the legacy Quark 9 folder - since Quark announced they won't be supporting it anymore anyway, and it crashes on launch now. I'm wondering if there are legacy Quark files installed on the system in various places slowing down Quark 2015 launching? Thoughts? Thank you.
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby shaun » 19 Oct 2015, 04:30

ExtensisFontManagementQXT2015.xnt
If it's not in theXTensions folder check it's not in the XTensions Disabled folder.
Check Suitcase Fusion 6 "Manage Plug-Ins" where you can sort out all the Quark extensions aavailable for your Qk versions.
shaun
 
Posts: 339
Joined: 14 Jan 2006, 13:12

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 19 Oct 2015, 06:14

Hi djt,

Preferences are here by default: /Users/<yourname>/Library/Preferences/Quark/QuarkXPress 2015/
Delete everything in that folder.
Start QuarkXPress.

QuarkXPress will start creating new preferences, so if you do not see new prefs in that folder afterwards, then you probably use a different Preferences folder.

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5217
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby djt » 19 Oct 2015, 11:23

This is very confusing.

I have QuarkXpress 9, 10, and Quark 2015 installed on my MacPro. I have searched individually and globally and the Extensis Suitcase Fusion extension doesn't exist in any extension folder or anywhere on my MacPro. Suitcase Fusion 6 was already installed on the MacPro (late 2013) with the El Capitan updater added before I installed the Quark 2015 (and updater). So I'm wondering perhaps I am missing that Suitcase xtension because it was never installed? Or else, when I disabled the Quark auto-activation plug-ins in the SF6 plug-ins manager it automatically deleted those xtensions?

In addition, the Quark 2015 preferences folder is empty. Note: the Library doesn't reside in users>library as you suggested, it is actually one level up at the top next to Users and System in the hierarchy – apparently El Capitan sets it up slightly differently.

So as far as deleting those files go, I can't because they are not to be found.

Separately, the inability to launch Quark 2015 without crashing was solved after I ran Disk Utility. What's odd about this is I had already done that plus rebuilt my PRAM, SMC and ran DiskWarrior, so my Mac was in great shape before the Quark 2015 starting crashing again. SP far, it appears to be very unstable in El Capitan and prone to suddenly start crashing for no particular reason. For the moment t's it's running. Just no auto activation.

I have responded to Extensis tech support and run a major diagnostic with a tool they sent me, and gave them a lot of info and files. Lets' see what where that ends up.
djt
 
Posts: 10
Joined: 28 Apr 2014, 13:23

Re: Quark 2015 not compatible with Suitcase Fusion in El Cap

Postby Matthias Guenther (Quark) » 19 Oct 2015, 14:57

Hi djt,

since a few OS X versions now Apple hides the User's Library. Go to Finder, hold the option key and choose menu "Go > Library" please. Then navigate the path down as specified above.

Do you see it now?

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5217
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Next

Return to QuarkXPress 2015/2016: XTensions modules for QuarkXPress

Who is online

Users browsing this forum: No registered users and 1 guest