Nothing but black pages from exported HTML5

Ask questions about creating HTML5 Publications (fixed or responsive) using QuarkXPress 2016 and 2017. HTML5 Publications allow you to create online publications with near-WYSIWYG typography and design and app-like interactivity – at no extra cost.

Nothing but black pages from exported HTML5

Postby Slickriptide » 06 Jun 2016, 12:11

Simple description -

I make digital layout and export it as HTML5.

I copy the folder to my company's web server.

I load the index.html. The Quark App Studio logo comes up and does it's "loading..." animation.

The player launches, but the background is black and there are no images or text to be seen.

Clicking the left and right arrows causes a preview image of the previous/next page to flash by, and something that appears to be a scroll bar is shown but otherwise the screen is black.

The "slide picker" appears to interact as expected, but picking a page from it gives the same result.

I tried making a layout that consisted of nothing more than one text box with "Now is the time for all good men to come to the aid of the party". Same result.

I tested with Chrome, Edge, and Mozilla. I guess I could try and find where Internet Explorer is on Windows 10 and try that, though it would be immensely silly if a "HTML5" presentation only worked on one specific browser, so I assume that won't actually accomplish anything.

Any ideas? Is there a configuration setting that I've missed?

***EDIT***

This is Quark 2016 on Windows 10
Slickriptide
 
Posts: 16
Joined: 24 Feb 2009, 16:30

Re: Nothing but black pages from exported HTML5

Postby Matthias Guenther (Quark) » 06 Jun 2016, 14:52

Hi Rip,

have you tried it out of QuarkXPress first, so by pressing the Preview button? Does that work?

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5196
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Nothing but black pages from exported HTML5

Postby Slickriptide » 06 Jun 2016, 15:47

As it happens, I found a solution.

I was using the developer tools in Chrome to inspect the pages when I ran into an error message about line 1 on the page I was viewing.

I took a look at the HTML in the file "./html5output/portrait2.html", which was page 2 of the digital publication.

The first line looked like this:

Code: Select all
<?xml version="1.0" encoding="UTF-8"?><html xmlns="http://www.w3.org/1999/xhtml">


The web server in question (due to be replaced) is running an old version of PHP that assumes <? is a way of invoking PHP. That makes it a problem here, rather than a problem with the HTML5 output from Quark. Since this server is due to be replaced with an updated server that properly uses <?php for its scripting tags, the problem will solve itself in due course.

In the meantime, an HTML5 document doesn't need that XML header. I removed the XML declaration from each of the portraitX.html files. After that, the error was gone and the digital publication viewer worked as intended.

As far as I can tell, the removal of the XML declaration hasn't affected the functions of the App Studio built-in menu, so the XML declaration is pretty much gratuitous. It doesn't hurt anything on a modern system but it's unnecessary.

That solves my problem, as I can just filter the pages to remove the XML declaration if I decide to try using the online publication.

***edit***

As for the preview, while I know there's supposed to be a preview button, I never found it. Where is it located?
Slickriptide
 
Posts: 16
Joined: 24 Feb 2009, 16:30

Re: Nothing but black pages from exported HTML5

Postby srmareedu » 06 Jun 2016, 23:58

Hi Rip,
You can find Preview HTML5 Publication icon at the bottom of the layout.
Preview Icon.PNG
Preview Icon.PNG (95.46 KiB) Viewed 2559 times

Preview HTML5 Publication: Click this icon to generate a preview of the layout as
an HTML5 Publication. This allows you preview your current layout in a browser,
before actually exporting or uploading to the portal.
srmareedu
Quarkian
Quarkian
 
Posts: 32
Joined: 30 Apr 2015, 06:23

Quark2016, HTML5, FTP

Postby realsole » 17 Jan 2017, 15:14

I'm throwing this out to the community.
I've exported a Quark 2016 document as HTML5.
In preview it shows up great.
But after FTP to web site, it shows blank.
The problem is most likely with the permissions, But I've changed the permissions in a variety of different ways but just can't get it to work.
If anyone has experienced a similar problem and solved it, would you please let me know what you did to make it work.
I'm on mac, latest version, quark2016. my web host is dreamhost. And I use Transmit for FTP.
Thank you!
realsole
 
Posts: 8
Joined: 09 Jan 2017, 22:56

Re: Nothing but black pages from exported HTML5

Postby realsole » 17 Jan 2017, 22:10

I have the same problem with blank pages, but removing the code as you suggested doesn't do the trick.
Any other ideas?
realsole
 
Posts: 8
Joined: 09 Jan 2017, 22:56

Re: Nothing but black pages from exported HTML5

Postby Matthias Guenther (Quark) » 18 Jan 2017, 01:03

Hi realsole,

how are you viewing the HTML5 Publication?

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5196
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Nothing but black pages from exported HTML5

Postby realsole » 18 Jan 2017, 07:58

When I click on Preview at bottom right, the preview looks great. But when I FTP the files to a public web server, and view index.html on safari or firefox, it's blank. I'm using a mac.
realsole
 
Posts: 8
Joined: 09 Jan 2017, 22:56

Re: Nothing but black pages from exported HTML5

Postby Matthias Guenther (Quark) » 18 Jan 2017, 08:37

Do you know what webserver your webhoster is running? Apache? IIS? Other?

Thanks
Matthias
Feel there should be more chatting, more tips, more user interaction?
Join us on Facebook, a forum-like group with over 2,000 QuarkXPress fans interacting:
http://www.facebook.com/groups/quarkxpress



Image
User avatar
Matthias Guenther (Quark)
Quarkian
Quarkian
 
Posts: 5196
Joined: 04 Jun 2004, 15:06
Location: http://bit.ly/QuarkHamburg

Re: Nothing but black pages from exported HTML5

Postby realsole » 18 Jan 2017, 09:27

From a Nov 2016 post, "Apache HTTP Server. DreamHost currently runs version 2.2.22 of the open source HTTP Server. In the near future, DreamHost will update Apache to version 2.4."
realsole
 
Posts: 8
Joined: 09 Jan 2017, 22:56

Next

Return to HTML5 Publications – from scratch and convert from Print

Who is online

Users browsing this forum: No registered users and 1 guest