Font display problems with OSX update 10.3.5

Discuss functionality of QuarkXPress 10, 9 & 8 (and before) (excluding Digital Publishing).
For Digital Publishing functionality please refer to forums in the "Digital Publishing" group.

As QuarkXPress 1 thru 10 are not supported by Quark anymore, please upgrade to a newer version of QuarkXPress if you are looking for official support. Support options for supported versions are here: http://support.quark.com
KHCAP
Posts: 5
Joined: 10 Jun 2004, 18:39

Font display problems with OSX update 10.3.5

Post by KHCAP » 23 Aug 2004, 13:47

Thanks for the tip on the Font Cache purge... but unfortunately it didn't work. :( Any other tricks up your sleeve?? BTW, I'll take the Summer Fridays all year round!
:)

User avatar
PhilipTobias
Posts: 3
Joined: 10 Jun 2004, 16:41
Location: Boulder, CO USA
Contact:

Font display problems with OSX update 10.3.5

Post by PhilipTobias » 23 Aug 2004, 15:53

>>I had the same problem. For the three or so characters I needed in a 48 page document I substituted Wingdings which happened to have the same keyboard layout for those characters.


Today http://www.macfixit.com had a story about certain fonts not displaying after people upgraded to Mac OS X 10.3.5. BTW, I've experienced this problem with Zapf Dingbats too.

Here's a brief story quote from John, a graphic designer, who found that Minion Expert no longer displayed in QuarkXPress: "Apple confirmed, after a long serious call, that 10.3.5 did indeed change the way character maps were read....they assured me the font was in error and had me call Adobe. The font works perfectly in Illustrator, Photoshop and any Adobe software, but not Quark, FileMaker or Word. Adobe said that their own products does not call on the Apple font technology, and uses its own to render fonts on screen. Since Minion Expert did work in there programs, they deemed the font fully functional."

Interesting, huh? ...pt

KHCAP
Posts: 5
Joined: 10 Jun 2004, 18:39

Font display problems with OSX update 10.3.5

Post by KHCAP » 23 Aug 2004, 16:46

Thanks for the update... glad to hear it's not just me! So, if Apple broke it, are they gonna fix it??? :roll: This is a serious problem for a majority of their users! It scares me to try and go back to 10.3.4... not sure I am qualified to do it correctly without messing something else up!!

Thanks again!

orgel
Posts: 0
Joined: 23 Aug 2004, 21:15

Font display problems with OSX update 10.3.5

Post by orgel » 23 Aug 2004, 21:58

Darn right this is a serious problem.

I'm running OS 10.3.5 on a dual-1.8GHz G5. As others have mentioned, since the 10.3.5 update, Adobe Type 1 Zapf Dingbats does not display in some applications (not all), including Quark 6.1. When I was running 10.3.4 before the OS update, I did not have this problem.

I've run Font Cache Cleaner 1.0 a couple of times, I've repaired permissions, I've uninstalled and reinstalled Zapf Dingbats. I've even run DeepSix 1.2 a couple of times for good luck. My Zapf Dingbats (v001.004) scans clean in both Suitcase X1 (v11.0.2) and FontDoctor v6.1.0.

Here's what I found when I tried to see if Zapf Dingbats displayed in a number of applications:

QuarkXPress 6.1 -- No
QuarkXPress 5.01 (under Classic) -- Yes (!)
Suitcase X1 11.0.2 -- No
Word 2004 11.0.0 -- Yes
Illustrator CS 11.0 -- Yes
Photoshop CS 8.0 -- Yes
InDesign CS 3.0.1 -- Yes

Note that anyone who has to deal with client files doesn't have the dubious luxury of substituting Bitstream or dfont or OpenType versions of Zapf Dingbats.

I sure hope someone at Quark is talking to someone at Apple about this, because it's a very serious problem. I have little doubt that other Type 1 fonts are affected -- I can't wait to find out which ones.

Any indications of what's transpiring at Quark or between Quark and Apple in terms of addressing this problem would be most appreciated. I'm dying here.

--David

mutz
Posts: 0
Joined: 17 Aug 2004, 07:40

Font display problems with OSX update 10.3.5

Post by mutz » 24 Aug 2004, 02:36

i got some very strange behaviour in suitcase....
i can actually see the postscript version in suitcase (but it doesn't display in quark :(
This is the how-to
open up your postscript version in fontlab, fontographer, transtype,...
and create a truetype version of it...
in suitcase i had a folder zapfdingbats PS with the postscript version in it not displaying
accidently i dragged the truetype version in the same folder in suitcase....
now both fonts are displaying fine...
i double checked this on another affected system...
:?:
anybody
codepages?
hmmm
here are 3 links:
zapf dingbats Postscript http://rastamutz.spymac.net/dingbatsps.sit
zapf dingbats converted to truetype: http://rastamutz.spymac.net/dingbatstt.sit
zapf dingbats BitStream: http://rastamutz.spymac.net/bt.sit

try it for yourself...
and post this to other forums...
and yes i know this is illegal...

:wink:

orgel
Posts: 0
Joined: 23 Aug 2004, 21:15

Font display problems with OSX update 10.3.5

Post by orgel » 24 Aug 2004, 06:18

[strong]mutz:[/strong]in suitcase i had a folder zapfdingbats PS with the postscript version in it not displaying
accidently i dragged the truetype version in the same folder in suitcase....
now both fonts are displaying fine...

I can confirm that this works. If both the TrueType and the Type 1 version of Zapf Dingbats are in the same folder and active in Suitcase X1, both versions will preview.

This is interesting, but as mutz noted, the the Type 1 version of ZD still doesn't display in QuarkXPress 6.1, so we've still got a big problem.

--David

KHCAP
Posts: 5
Joined: 10 Jun 2004, 18:39

Font display problems with OSX update 10.3.5

Post by KHCAP » 24 Aug 2004, 08:32

Does anybody know what the three ZapfDingbat files located in the Quark 6.0 > jaws > ttfont folder are for? Could these be removed? Or replaced? Other than that, I don't have any other versions anywhere except my font folder for suitcase x1. Thanks for any thoughts on this!

mutz
Posts: 0
Joined: 17 Aug 2004, 07:40

Font display problems with OSX update 10.3.5

Post by mutz » 24 Aug 2004, 08:35

you can delete them... it's a sort of cache for quark i think...
search in this forum and u will find more info 'bout it...

cya

DDMantis
Posts: 0
Joined: 26 Aug 2004, 11:23

Font display problems with OSX update 10.3.5

Post by DDMantis » 30 Aug 2004, 11:55

In addition to Minion Expert and Zapf Dingbats, I've discovered that Utopia Expert (a type 1 font by Adobe) also does not display, but does print, in 10.3.5.

In 10.3.4, the fractions from those other fonts didn't display, but the rest of the characters were fine.

Unfortunately, those fractions are used a lot in our magazine's classified pages, and the non-displaying small caps in Minion and Utopia are used for our folios and page numbers!

Has anyone with Fontographer tried that TrueType Zapf Dingbats trick with Minion Expert?

mutz
Posts: 0
Joined: 17 Aug 2004, 07:40

Font display problems with OSX update 10.3.5

Post by mutz » 31 Aug 2004, 08:53

Be sure u import the font metrics into fontographer/fontlab (i prefer using fontlab...)
converting dingbats was no probelm cause that fonts asn't got any metrics in it...

Post Reply

Return to “QuarkXPress 8, 9 & 10: General”