Font display problems with OSX update 10.3.5

Discuss functionality of QuarkXPress 10, 9 & 8 (and before) (excluding Digital Publishing).
For Digital Publishing functionality please refer to forums in the "Digital Publishing" group.

As QuarkXPress 1 thru 10 are not supported by Quark anymore, please upgrade to a newer version of QuarkXPress if you are looking for official support. Support options for supported versions are here: http://support.quark.com
mol_jim
Posts: 0
Joined: 07 Jun 2004, 14:21

Font display problems with OSX update 10.3.5

Post by mol_jim » 04 Oct 2004, 10:21

[strong]Tom Owens:[/strong]Spend a few bucks and buy a new one.

Buy a new what? I purchased a new version of Zapf Dingbats which does work fine for new documents. My problem is I have hundreds of exisiting Quark documents which use Zapf Dingbats and Quark does not recognize the new font as being the same. I have to replace each instance of the font and the baseline of the new font is not the same. That is why I was very interested when Mike wrote: "quark also seems to swap it out for font id 13 dingbats just fine"

Partial
Posts: 0
Joined: 06 Oct 2004, 13:15

Font display problems with OSX update 10.3.5

Post by Partial » 18 Oct 2004, 15:57

I am working with a user who has the same problem on her Powerbook with OS 10.3.5.

I found this article on the Suitcase site:

http://www.extensis.com/en/support/kb_a ... er=1302204

Thought I would post the link since no has mentioned it. Extensis says that zapfdingbats won't preview in Suitcase because it is a unicode font and Cocoa programs such as Suitcase deal with unicode fonts differently. Anyway, quick summary but there are more details there.

robindreyer
Posts: 0
Joined: 19 Oct 2004, 12:27

Font display problems with OSX update 10.3.5

Post by robindreyer » 19 Oct 2004, 12:32

I have has this problem with Perpetua Expert--some characters will print but will not display, others won't print or display. I repurchased the whole package from Linotype, but it didn't fix it. Apple disavows any problem with any Type 1 fonts. I've finally worked around it by using the numbers in the OSF and SC cuttings. The fractions in Expert, which don't exist in any other cuttings are working fine.

What's really strange is that when I select the option in Font Book that shows every character in the set, all of the missing characters show up. This makes me think that Font Book can see them, but Quark cannot. I have exactly the same set of problems with Microsoft Word, which has made me think this is really a System problem. But I see here that other people have had different results with several different applications.

Robin

Pixolab
Posts: 0
Joined: 20 Oct 2004, 10:34

Font display problems with OSX update 10.3.5

Post by Pixolab » 20 Oct 2004, 10:49

Here's what fixed it for me and my users...

We use Quark 4 & 6, and Suitcase X.02. We have a few fonts in our Classic System Folder, like Zapf Dingbats. We had removed the Zapf from System::Library::Fonts so only the Classic version would be active. When I restored the .dfont Zapf to its original location, it showed up correctly in Quark 6. In Suitcase, both the Classic and .dfont versions show as activated, though neither will preview. However, Zapf now displays and prints correctly in both Quark 4 and 6. If you select Usage in 4, it points to the Classic Zapf; Usage in 6 points to the .dfont version. Hope this helps someone!

kmaple
Posts: 0
Joined: 08 Oct 2004, 08:33

Font display problems with OSX update 10.3.5

Post by kmaple » 01 Nov 2004, 18:04

Does anyone know if this problem with the expert fonts has been fixed in 6.5?

Linda
Posts: 1510
Joined: 02 Jun 2004, 14:57

Font display problems with OSX update 10.3.5

Post by Linda » 02 Nov 2004, 17:29

kmaple, it's an OS thing, not an XPress thing... happens in other apps too, from what I read... also read that no, it's still there in XPress 6.5.

Try this link to read more about it:

http://www.macmedics.com/tenthreefive.htm

peace,
Linda :)

Linda
Posts: 1510
Joined: 02 Jun 2004, 14:57

Font display problems with OSX update 10.3.5

Post by Linda » 02 Nov 2004, 17:30

. . .

kmaple
Posts: 0
Joined: 08 Oct 2004, 08:33

Font display problems with OSX update 10.3.5

Post by kmaple » 02 Nov 2004, 17:37

Linda, Thanks for the reply. Your right it is still a problem in 6.5 hope this is corrected with Mac OS update soon. :(

trounce42
Posts: 0
Joined: 05 Nov 2004, 16:48

Font display problems with OSX update 10.3.5

Post by trounce42 » 05 Nov 2004, 16:52

I was having the same problem with ZapfDingbats and other expert fonts, until the Mac OSX release of the 10.3.6 update..

(They work fine for me now.)

User avatar
PhilipTobias
Posts: 3
Joined: 10 Jun 2004, 16:41
Location: Boulder, CO USA
Contact:

Font display problems with OSX update 10.3.5

Post by PhilipTobias » 05 Nov 2004, 17:18

>>I was having the same problem with ZapfDingbats and other expert fonts, until the Mac OSX release of the 10.3.6 update..
(They work fine for me now.)

Great news, I'll have to give this brand new OS X update a try. Your notice was the first I heard about it. Looking into it, the update is alleged to fix the following problems:

* Addresses an issue for Mac OS X 10.3.5 in which some glyph fonts, certain "Expert" or "dingbat" fonts, would no longer appear in some applications.
*Resolves a situation in which incorrect characters could show up for some fonts.

...pt

Post Reply

Return to “QuarkXPress 8, 9 & 10: General”