Applescript to deal with diacritics

Discuss AppleScripting for QuarkXPress 10, 9 & 8 (and before)
Jean-Marie Schwartz
Posts: 1174
Joined: 23 Nov 2004, 04:30

Applescript to deal with diacritics

Post by Jean-Marie Schwartz » 06 Mar 2013, 23:37

Then can you try again appending "of it" (without quotes) after the word contents?
It's always hard to troubleshoot that kind of thing when everything's OK on coder end. Maybe someone else would know the reason why it's not working on your side.

rgbherman
Posts: 0
Joined: 15 Jan 2007, 14:37

Applescript to deal with diacritics

Post by rgbherman » 08 Mar 2013, 03:48

Ran the script with the suggested change in Quark 8.5 and 9..
Resulterror "QuarkXPress got an error: Cant make some data into the expected type." number -1700 to item
Applescript gray-highlighted this entire line:
set contents of it to my ReplaceChars(the_text_to_be_replaced)

BTW, I was running some Applescript for TextWrangler. Two computers ran the script successfully. A third would not. (Same OS, same versions of TW.) Didn't like the word "project" in front of "window 1." When i took it out all good. So I definitely understand there can be differences. Certainly does make it tough to long-distance diagnose.
Fingers crossed we can figure this out...

Jean-Marie Schwartz
Posts: 1174
Joined: 23 Nov 2004, 04:30

Applescript to deal with diacritics

Post by Jean-Marie Schwartz » 08 Mar 2013, 23:26

Well Ive tested my code here at home and it errors too :-( Ill try to dig a bit deeper later this week if I can. Sorry!

rgbherman
Posts: 0
Joined: 15 Jan 2007, 14:37

Applescript to deal with diacritics

Post by rgbherman » 08 Apr 2013, 05:20

Seemed like we were close to a solution. Any chance we could look at this again...? The project that involves this solution is coming up soon.

Post Reply

Return to “QuarkXPress 8, 9 & 10: AppleScript”