simple script not working

Discuss AppleScripting for QuarkXPress 10, 9 & 8 (and before)
Post Reply
MaryJosh
Posts: 0
Joined: 28 Oct 2014, 06:10

simple script not working

Post by MaryJosh » 03 Jan 2015, 00:59

I am using Mac OS X (version 10.6.8), QuarkXpress 8.15 and Applescript Editor (version 2.3)

Why the below script is not working in my quark? Not only this script most of the scrip is not working in my quark.

Code: Select all

tell application "QuarkXPress"
	activate
	tell page 1 of document 1
		set text of text box 1 to "Test"
	end tell
end tell
Shows the result as below:

tell application "QuarkXPress"
activate
set every text of text box 1 of page 1 of document 1 to "Test"
--> error number -1728
Result:
error "QuarkXPress got an error: Can’t set every text of text box 1 of page 1 of document 1 to \"Test\"." number -10006 from every text of text box 1 of page 1 of document 1 to «class Test»

ddwebdev
Posts: 0
Joined: 11 May 2012, 12:34

Re: simple script not working

Post by ddwebdev » 03 Jan 2015, 14:10

Working well on
Quark 9.5
OS 10.9.5
applescript version 2.6
...
P.S. With your script, you have to create the textbox yourself before running it

try it with creating the textbox by script

Code: Select all

tell application "QuarkXPress"
	activate
	tell page 1 of document 1
		make new text box at beginning with properties {bounds:{"1 in", "1 in", "3 in", "6 in"}}
		set text of text box 1 to "Test"
	end tell
end tell

Jean-Marie Schwartz
Posts: 1168
Joined: 23 Nov 2004, 04:30

Re: simple script not working

Post by Jean-Marie Schwartz » 05 Jan 2015, 05:20

As far as I remember there was (is) a bug with any text scripting. One would need to deactivate some East Asian XTs. Search the forum and you'd find some threads about that. HTH.
Jean-Marie Schwartz

= Mac Pro Quad-Core Intel 2.8 GHz • 10 Go 1066 MHz DDR3 • Mac OS 10.10.5 • QuarkXPress 9.5.4.1 + QuarkXPress 2017 • Adobe CS5 =

Post Reply

Return to “QuarkXPress 8, 9 & 10: AppleScript”