No pictures with Hyperlinks

Discuss the HTML4 features and Web layout provided in QuarkXPress 8 and 9 (and before).

If you are interested in HTML5 publishing, then please visit the section about Digital Publishing and look at HTML5-based apps or HTML5 Publications.
Locked
John Jefferson
Posts: 0
Joined: 02 May 2012, 05:21

No pictures with Hyperlinks

Post by John Jefferson » 02 May 2012, 01:20

1. I am using the 30 day trial version (9.2).
2. When I set up 2 pages with a picture on each page and a hyperlink from one picture on page 1 to page 2, there was a problem clicking to page number 2.
3. With Page > Preview HTML the picture is showing on page 1, but clicking on the hyperlink gave an error message: "Firefox can't find the file at /C:/DOCUME~1/Ordinary/LOCALS~1/Temp/QUARKT~1/Export2.htm"
4. Having exported to HTLM the link worked but neither picture is displayed. Just an empty box containing the file name (no path)
5. Then I changed the default paths from for "Save/SaveAs" and the "Site Root Directory" from one of my own choice to the one in point 3 andre-exported to HTML. It worked perfectly! Page > Preview HTML, though, still had the same error message as before.

6. Does anyone know whether this arbitrary path requirement and the preview problem have anything to do with it being a trial installation of QuarkXpress?

User avatar
Sarbjit Singh
Quarkian
Quarkian
Posts: 417
Joined: 22 Jan 2009, 04:44
Location: India
Contact:

No pictures with Hyperlinks

Post by Sarbjit Singh » 02 May 2012, 19:34

Here is how web export works:
Preview HTML generates HTML for the current page, only. So the hyperlinked pages will not work.
HTML export creates HTML for all the pages, so the hyperlinks will work. The images are exported to a folder name "image". If you are opening the HTML from the correc place, you should see the pictures. You should check the HTML source and verify that the "src" attribute for the images is set correctly.
The trial version has no limitations that would affect Web Export.

John Jefferson
Posts: 0
Joined: 02 May 2012, 05:21

No pictures with Hyperlinks

Post by John Jefferson » 03 May 2012, 05:02

Thanks Sarbjt. So I just need to export my HTML files to /C:/DOCUME~1/Ordinary/LOCALS~1/Temp/QUARKT~1 and my pictures to its Image Folder.
John.

User avatar
Sarbjit Singh
Quarkian
Quarkian
Posts: 417
Joined: 22 Jan 2009, 04:44
Location: India
Contact:

No pictures with Hyperlinks

Post by Sarbjit Singh » 03 May 2012, 18:27

Not exactly. I mean wherever you export as HTML, you should get .html for every page and an image folder with all images used in these pages. So you can choose where to export. The image paths should be "relative" so that you may move the folder to any location and still see all your images.

John Jefferson
Posts: 0
Joined: 02 May 2012, 05:21

No pictures with Hyperlinks

Post by John Jefferson » 04 May 2012, 04:14

I have got it to work from a folder of my choice now. My hard disk is partitioned into 2: the C disk is the system disk and the D disk I use for my data. I have not yet got hyperlinked pictures to work on the D disk but there are no problems with a C disk folder of my own choice.

Locked

Return to “QuarkXPress 8 & 9: Web authoring (HTML4) - discontinued”