Java gone wild!

Discuss Quark® License Administrator (QLA) setup and functionality, which allows you to run concurrent licenses of QuarkXPress inside your organization.
Post Reply
jswingchun
Posts: 0
Joined: 21 Sep 2005, 11:49

Java gone wild!

Post by jswingchun » 28 Nov 2007, 08:46

Sometimes the java process related to QLA on my server will go crazy and peg the processor at 100%.

OS X server, 10.4.9, QLA 4.01 running as a service

I saw someone had posted a thread with a similar problem back in 2004 that was not resolved.

Two questions:

1 - Has anyone else seen this or know of a fix?

2 - I can fix it by killing the service using the stopQLAService.command file but I can't figure out how to restart the service short of rebooting the computer. Any help on restarting the service without rebooting?

jswingchun
Posts: 0
Joined: 21 Sep 2005, 11:49

Java gone wild!

Post by jswingchun » 29 Nov 2007, 11:17

Okay, at to question number two in my original post, I figured out that I can just launch the gui interface QLAServer until the next time I need to restart the server. Then it will relaunch as a service at that point. That gets me thru most issues I would face.

I would still like to know if there is a way after I stop the QLAService to relaunch it as a service without rebooting the Mac. I would love to have a little command script like stopQLAService.command to start the service back up.

jswingchun
Posts: 0
Joined: 21 Sep 2005, 11:49

Java gone wild!

Post by jswingchun » 11 Dec 2007, 09:56

Isn't this great? I post and I respond to my own posts.

As a follow up, in case anyone is looking for this information in the future, I received this from Quark Tech Support yesterday:

I would like to inform you that in order to start the Quark License Administrator as service, the only option is to restart the system.

If we double click on the QLAServer icon the Quark License Administrator will be launched as an application.

We regret the inconvenience caused and solicit your cooperation.


I'm not exactly sure what that "solicit your cooperation" bit means, but at least I have an answer now.

hammen
Posts: 0
Joined: 23 Jan 2008, 10:54

Java gone wild!

Post by hammen » 23 Jan 2008, 11:02

We have this problem with QLA 4.01 (running as a service) on an Intel Xserve running 10.4.11 Server. What we end up doing is using Activity Monitor to kill the offending 100% java process, then, from Terminal:

sudo SystemStarter stop QLA
sudo SystemStarter start QLA

This fixes the problem (until the next time QLA dies). Just noticed there's a QLA 4.5, so I've just downloaded it and hope it addresses this issue...

--Robert

jasonm
Posts: 8
Joined: 28 Jun 2007, 08:08

Java gone wild!

Post by jasonm » 24 Jul 2008, 08:49

I think it is similar to our own QLA CPU hog problem:
t/11214.aspx

rstasel
Posts: 0
Joined: 12 Aug 2010, 13:21

Java gone wild!

Post by rstasel » 12 Aug 2010, 07:29

As a point, I still have this issue with QLA 4.5 on 10.5.8. I've set it to run under java 1.4, and it still occurs. But then, I'm a bit concerned that Quark hasn't updated QLA in a couple years now... Only way we can fix it is to kill the offending java instance, then run QLA from the command (sudo /Library/StartupItems/QLA/QLA) line until the next server reboot. This really needs to be fixed. Seems that QLA will run at normal CPU levels for a couple days, then spike and completely monopolize one CPU. This is on a Xserve G5, running 10.5.8.

jasonm
Posts: 8
Joined: 28 Jun 2007, 08:08

Java gone wild!

Post by jasonm » 08 Jun 2011, 11:03

I have also had similar problems for years with the QLA on Windows. For a program that does so little and should require so few resources, it becomes a complete CPU hog.
I still cannot understand why Quark will not simply release QLA as a virtual appliance or at the very least make a version that runs on Linux.

Post Reply

Return to “Quark License Administrator”