Vista crashes

Discuss QuarkXTensions® and third-party XTensions® software
User avatar
PhilipTobias
Posts: 3
Joined: 10 Jun 2004, 16:41
Location: Boulder, CO USA
Contact:

Vista crashes

Post by PhilipTobias » 03 Nov 2004, 23:42

Hi, all. I recently installed the QuarkXPress 6.5 update on my Mac OS X 10.3.5 computer, so I wanted to try out the new QuarkVista image-processing XTension.

However, each time I try to open an effect (levels, curves, blur, etc.) from the palette, QuarkXPress crashes. I've tried this with new and existing documents, and with a variety of graphics.

Are there any known conflicts, or am I missing something?

TIA. ...pt

jonesy17
Posts: 278
Joined: 11 Aug 2004, 15:34

Vista crashes

Post by jonesy17 » 17 Nov 2004, 17:51

[strong]artbuczek:[/strong]Any suggestions?


Robert

jonesy17
Posts: 278
Joined: 11 Aug 2004, 15:34

Vista crashes

Post by jonesy17 » 17 Nov 2004, 19:30

My suggestion(s) was made with tongue planted firmly in cheek. But as the adage goes, 'Use the right tool for the right job."

jorskj
Posts: 0
Joined: 04 Aug 2004, 09:00

Vista crashes

Post by jorskj » 18 Nov 2004, 09:41

Im not sure whether this is the problem, but I also wanted to try Quark Vista and opened an old page with eps-files mounted. Nothing happened. Everything in the dialouge box was grey.

Then i found a post on a swedish site, that said Vista is only working with tiff or jpg, and that theres some kind of bug stopping it from doing anything with eps.

So i tried a new document mounted a Jpg-file and voila it was working. Only to find out that Vista must be one of the most meaningless new features Ive seen in Quark.

I agree completely with Robert. Stick to Photoshop and dont even bother to find out how it works. There are better things to do.

//Jrgen

atdesign
Posts: 1
Joined: 01 Jun 2004, 12:23

Vista crashes

Post by atdesign » 30 Nov 2004, 10:13

Hi !
[/b]

Dan Logan
Posts: 92
Joined: 15 Mar 2005, 09:57

Vista crashes

Post by Dan Logan » 14 Dec 2004, 15:23

QuarkVista was tested pretty rigorously in an external beta cycle and there are no known issues that would cause a crash when applying a Picture Effect to multiple unrelated pictures (of course it could crash on specific corrupt images, but if you're getting the same result from a variety of graphics then something else is wrong).

Have you tried troubleshooting your Preferences? You should try moving the Preferences folder to another location, re-launch QuarkXPress, then try a Vista Effect. By default QuarkXPress 6 puts preferences in ~/Library/Preferences/Quark/.

If that doesn't work I would suggest troubleshooting your other XTensions. Try moving everything except Vista.xnt and Quark Image Engine.dylib to the XTensions Disabled folder, then relaunch QuarkXPress and test. If that doesn't work then please email me an affected graphic file to test with.

As for EPS graphics, it's true that QuarkVista 6.5 cannot apply Effects to them. The problem here is that it's tricky to identify a "Photoshop EPS" as opposed to a "Generic EPS" (which may contain vector data). While it would technically be possible for us to rasterize a Generic EPS and then apply an Effect to it, we decided that it would be too easy for people to screw up their graphics. In other words, you should not pre-rasterize a vector EPS just to apply an Effect. We've solved that issue now and a future version of Vista will allow Effects on the "Photoshop EPS" format (note that this does not include EPS files saved from Photoshop with the "Include Vector Data" option checked). It's not exactly true that Vista only works with "tiff or jpg". Actually it works with almost all of the raster formats supported by XPress. I put EPS and PDF in the vector category even though they can do both (don't get me started on PICT and WMF). I can't think of many reasons to use EPS for raster graphics anymore, other than OPI and certain other special workflows.

Atdesign, what are the details of your crashes? Does it only happen on certain filters, but never on adjustments? Gaussian Blur for example takes a particularly long time to render on large files, could it be that you're testing Gaussian Blur and not waiting for it to render?

As for your comments about Photoshop, if you want to use the right tool for the job then you'll have to use Vista sometimes because it can do a number of things that Photoshop just can't, such as non-destructive filters and per-instance effects. For certain design problems this solves a huge problem that Photoshop doesn't address.

Sincerely,
Dan Logan
Technical Product Analyst
QuarkXPress Product Management

Diogo G
Posts: 0
Joined: 23 Jan 2005, 20:15

Vista crashes

Post by Diogo G » 23 Jan 2005, 20:45

Hi

QuarkVista crash with any Adjustment or Effect on any picture.

Yesterday was workyng fine. Changes made untill crash detection:

- Preferences:
Save/Auto Backup/other folder
Full res preview/Preview Cache location/other folder
Picture effects/Pict. eff. preset location/other folder
Picture effects/Pict. cache location/other folder

New locations: HD/Temp/QXP65/ indiviual folders for all with names similar to the preferences.

- Installed xtension
Kill Pasterboard for Q6

Made new download of vista and reinstalled it.
Tried the advices but nothing seems to correct the problem.

Any kind of help will be welcome - even a gun.... :cry:


-----
Mac Os 10.3.7

Diogo G
Posts: 0
Joined: 23 Jan 2005, 20:15

Vista crashes

Post by Diogo G » 24 Jan 2005, 03:00

Reinstalled quark and updates. After a few hours, the problem is found:

Full Res Preview and Vista Xtensions are in conflict.

I cannot have both at the same time.

.../...

Dan Logan
Posts: 92
Joined: 15 Mar 2005, 09:57

Vista crashes

Post by Dan Logan » 15 Feb 2005, 18:10

What version of Full Res Preview XT are you loading? It should be version 6.5, is it? I can't reproduce a conflict between the two on my machine.

-Dan

Chadmanii
Posts: 0
Joined: 06 Apr 2005, 11:10

Vista crashes

Post by Chadmanii » 06 Apr 2005, 11:34

O.K. Here is what I don't understand about Quark:

1) If Quark Vista requires Full Res Preview v. 6.5, then why didn't the 6.5 upgrade install it?

2) They feign ignorance. e.g. "I can't reproduce a conflict between the two on my machine." They must know that the 6.5 upgrade did not install the updated Full Res XT.

3) It is alway the user's problem. e.g. "What version of the Full Res preview XT are *you* loading?" (emphasis added). Well, I was loading the one that was installed by *your* software. You can also see this "User is at fault" tack in the post from 12/14/04.

Wouldn't it be easier for Quark to just say that during their "rigorous testing" that there is a known conflict between previous versions of the full res XT, that the upgrade did not install the current one, and that we should download and install it. (Perhaps in an ideal world include a link to the download.)

I'm sorry for venting, and I don't know if anyone is actually reading this. i hope the following is helpful:

I , too, had the same problem. Quark unexpectedly quit when I used Vista. I installed the latest verion of Full Res preview XT and now it works. It's that simple.

The Mac version of the XT can be found here:

http://download.quark.com.edgesuite.net ... view65.hqx

Post Reply

Return to “QuarkXPress 8, 9 & 10: XTensions modules”