Movie in flash

Ask specific questions about integrating audio & video functionality in interactive designs created with QuarkXPress 7, 8 & 9.
Please note that Flash (SWF) authoring is not supported in QuarkXPress 10 anymore.
R2
Posts: 0
Joined: 01 Oct 2007, 09:06

Movie in flash

Post by R2 » 04 Dec 2007, 02:28

I have a .MOV movie that I want to run in the swf file. I have tried to follow instructions in the help file, and read earlier posts on the subject.

Everything works fine in preview, but the exported file doesn't show any video.

I have tried "choose" and "external file" but no change.

How do I make the .MOV into a .FLV or .SWF?

When I do a preview the "FlashVideoConverter" starts and processes the video, it takes about 30 s.

Then when I do export, QID produces the swf file in "zero" time. My conclusion is that it never converts the video.

Can you please explain the procedure to make it work!

/Robert

Matthias Guenther (Quark)
Quarkian
Quarkian
Posts: 2490
Joined: 04 Jun 2004, 15:06
Contact:

Movie in flash

Post by Matthias Guenther (Quark) » 04 Dec 2007, 02:59

Hi, Robert,

Interactive Designer includes an encoder we licensed (from Wildform) which encodes MOVs into FLV or SWFV (the only two formats Flash can play).

You seem to do everything right, I assume you create a picture box and load the MOV via choose (external will NOT work, as then the MOV is not encoded and Flash cannot play MOVs).

Now you should see an Encoding options button at the very bottom of the object definition (in object tab). What are your settings there?

Thanks
Matthias

R2
Posts: 0
Joined: 01 Oct 2007, 09:06

Movie in flash

Post by R2 » 04 Dec 2007, 03:34

I have a screen dump of the settings but I don't know how to show it in the forum.

I click on the Encoding button ("Exportera instllningar", since I have a Swedish QID)

I don't change anything, and click OK. Nothing happens other than the window closes. What should happen?

My .mov movie is 10 MB, 200x150 pixels

Matthias Guenther (Quark)
Quarkian
Quarkian
Posts: 2490
Joined: 04 Jun 2004, 15:06
Contact:

Movie in flash

Post by Matthias Guenther (Quark) » 04 Dec 2007, 03:38

Hi, Robert,

when you close the settings dialog, nothing should happen, as encoding only takes place when previewing or exporting.

So preview works and export not. How do you export? As a projector? As part of a web page?

Also, what might help (just an idea) is what if you adjust the movie to be 100% (scaling) and fit box to picture (well, movie) via contextual menu?

Last test please: In Usage > Multimedia tab, what does it say for your movie? Convert option on?

Thanks
Matthias

R2
Posts: 0
Joined: 01 Oct 2007, 09:06

Movie in flash

Post by R2 » 04 Dec 2007, 03:54

Hi,

the picture box is 267x200 pixels and the movie is the exact same size.

I export via "Archive > Export > Exporter for Macromedia Flash"

This has worked with other swf I have done. This is however the first with a video.

What is "projector"?

In Usage > Multimedia the convert option is a blue square with a - in it.


/Robert

Matthias Guenther (Quark)
Quarkian
Quarkian
Posts: 2490
Joined: 04 Jun 2004, 15:06
Contact:

Movie in flash

Post by Matthias Guenther (Quark) » 04 Dec 2007, 04:33

[strong]R2:[/strong]What is "projector"?
A projector is an executable file, basically it embeds the Flash Player and the SWF into one file, so that you can doubleclick it to player. It is an export option in the export dialog.

This way you can create an EXE for Windows or an APP for Mac.

Back to your problem:
1. Did you choose FLV or SWFV in your object settings? What is you switch it?
2. What kind of a MOV is it? Which app created it? Do other MOVs work or just not that one?
3. When you export you say it takes 30 seconds. Can you use Spotlight to see whether any movie is being exported? It should have a recent time stamp and be called the same as your MOV object.

Regards
Matthias

R2
Posts: 0
Joined: 01 Oct 2007, 09:06

Movie in flash

Post by R2 » 04 Dec 2007, 05:11

Thanks for your effort!

I have chosen FLV. Will try another movie later, haven't got time just now.

The movie is made with Quicktime Pro. Originally it's a wmv file downloaded from Internet via FlipforMac

I usually upload the swf file to a web page, embedded in a index.html file

I found the Projector setting now, but I havent used it before. It makes no improvement


/Robert

R2
Posts: 0
Joined: 01 Oct 2007, 09:06

Movie in flash

Post by R2 » 05 Dec 2007, 10:08

Hi, I'm back!

I have tried with other "pure QT" movies, it still doesn't work.

What do you mean by "Also, what might help (just an idea) is what if you adjust the movie to be 100% (scaling) and fit box to picture (well, movie) via contextual menu?"

Where do I do that?

Preview works, export doesn't! It's really disappointing

Hope for help

/Robert

Matthias Guenther (Quark)
Quarkian
Quarkian
Posts: 2490
Joined: 04 Jun 2004, 15:06
Contact:

Movie in flash

Post by Matthias Guenther (Quark) » 05 Dec 2007, 10:24

Hi, Robert,

can't think of anything else from remote.

I will ask our Quality Assurance to contact you, probably best if we have a look at your file (QXP) and your movie. Sorry for the inconvenience.

Best regards
Matthias

Kabir(Quark)
Posts: 5
Joined: 30 Oct 2006, 23:29

Movie in flash

Post by Kabir(Quark) » 07 Dec 2007, 01:00

Hi Robert,

It appears that the folder you are exporting to has some Swedish character" (non english). Could you please try exporting to a folder/location that does not have any special characters , maybe a simple name like "Export folder" would do.

Please let us know if this works.


Thanks and Regards,
Kabir
kschandhoke@quark.com
QuID QA

Locked

Return to “Video & Audio”